Pre-compose but new composition should have the dimension of the layer (for ex a solid)

Example

My comp is 1920x1080 and inside a solid, (image or something else) of the dimensions 1000x1000

If I pre-compose the layer I end with a nested composition of the dimension of the composition I started from: 1920x1080

It is possible to pre-compose and automatically create the new composition with the dimensions of the solid I pre-composed? 1000x1000 in this example.

I know I can just modify the composition dimension after in the “Composition Settings” window, but this gets repetitive and boring if you have more than three compositions to change.

CS4 version


:wink:

great! works perfectly!

thank you for the help! :slight_smile:

doru said

Example

My comp is 1920x1080 and inside a solid, (image or something else) of the dimensions 1000x1000

If I pre-compose the layer I end with a nested composition of the dimension of the composition I started from: 1920x1080

It is possible to pre-compose and automatically create the new composition with the dimensions of the solid I pre-composed? 1000x1000 in this example.

I know I can just modify the composition dimension after in the “Composition Settings” window, but this gets repetitive and boring if you have more than three compositions to change.

CS4 version

If you check leave all attributes in AE, then the new comp will have the dimensions of the solid, not the composition, but no effects / keyframes etc. will be moved into the new comp. Sounds like you want to precompose and move some attributes, but leave others… in which case you could do with Smart Precomposer…

doru said

great! works perfectly!

thank you for the help! :slight_smile:

No problem Doru.

felt_tips said

If you check leave all attributes in AE, then the new comp will have the dimensions of the solid, not the composition

wait a minute here WTF is going on? I made several tests, precompose with “leave all attributes”, precompose with “move all attributes” and every time I ended up with a composition the same size as the starting comp.

So I made this thread.

Now I saw you message and I said to me, let me try again just to be sure and, with “leave all attributes” it made the come THE SAME SIZE AS THE SOLID

I have no idea what is happening. it didn’t work yesterday.

Strange, but is ok with me, hope is working like this in the future :slight_smile:

That script is also awesome.

Thank you everyone.

As far as I have experienced, if you pre-compose a single layer, you will get the option of leaving attributes, which will crop the comp to the size of your contents. If you pre-compose multiple layers, that option won’t be available.

However, I came across an auto crop script that does the job, even with animations.