Plugin translation

I am trying to translate a plugin that I did before many many times, te load_plugin_textdomain is returning true but no translation is done in the plugin this also applies to older plugins that worked fine.

I tried a fresh install of WordPress 6.3 but nothing, are there any changes in the latest versions of WordPress that I don’t am now aware of I have been absent a long time, I am very sick.

Could be plug-in issue or make sure where you put “po/mo” files to the WordPress directory.

The po and mo files are in the plugin directory in the language folder and the load_plugin_textdomain returns true which means they are loaded but no translation is visible on the page, it is wired that even plugins that worked fine do not work anymore… I am referring to the translation part.

You gotta figure out the problem on your own. It will require “bug/issue” check to find the problem first if it’s related to WordPress or plugin, then it’d be required to check few others things if everything is well coded.

Feel free to contact the item author for the free support. You can try with the lower version of WordPress as well if you think it’s related to WP version ( try with 5.8 / 5.9 )

I even tried a plugin that I bought that worked fine and it does not work, I tried a fresh WordPress install, it makes no sense :slight_smile: