Php version for eClipse Photo Portfolio Theme

Hi,

I have the eClipse Photo Portfolio Theme, and i had the 5.6 php version… I need to have now the 7.2. or 7.3.

But when i put a version after 5.6 : i have a white page.
So i use an extension to see witch extension is not compatible, and it said that the theme is not compatible:
So what can i do ?

FILE: /home/clients/98555a820823918f6e54a58a41ec2511/web/new/wp-content/themes/gt3-wp-eclipse/core/xml-importer/importer.php

FOUND 2 ERRORS AND 1 WARNING AFFECTING 3 LINES

66 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
705 | ERROR | preg_replace() - /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
773 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.

Can someone help me ?
Is the theme not supported for new version of php ??