PHP Update showing error in Slider Revolution and LayerSlider

Hey there,
Tried updating PHP 7.0 to PHP 7.4 on CPanel to fix this [PHP UPDATE INSECURE VERSION OF PHP ERROR] on WordPress.

But, after updating, the Slider Revolution i.e. revslider plugin folder showing some errors, including:

  1. create_function() deprecated
  2. continue targeting switch is equivalent to break,
  3. And other such errors including the Fatal Error

To fix these error, do I need to buy the premium version of Slider Revolution, since the current version is 5.2 and outdated. I can’t update it, since it is asking to buy the Premium version for update.

I am using Bridge theme.

Hi @ThinkGeneric,

Thanks for using Slider Revolution. Yes, updating the Slider Revolution plugin to the latest version will fix the PHP error you had there. Here is the link to our official product https://codecanyon.net/item/slider-revolution-responsive-wordpress-plugin/2751380/

Thanks!

KC
ThemePunch

Thanks!
We should buy the premium version of the product and then update site to PHP 7.3 from PHP 7.0? By just clicking on the “Premium” under “Installed Plugins”, we should buy the plugin?

Hi @ThinkGeneric,

Thanks for your reply. You can use the product link that I’ve posted on my previous reply. Then, activate the plugin and update the plugin to the latest version. Once you’ve done that, you can update the PHP to the latest version. If you’ve further questions, you can email us at help@themepunch.support

Thanks!

KC
ThemePunch

Sure!
Envato WordPress Toolkit deprecated, so I deactivated it and installed the new Envato-Market plugin and activated it. After that, generated a Token and verified it.
Now, I should buy the Slider Revolution Plugin and update. Hope that’s correct.

Hi, Bought the plugin. Installed it and updated the PHP version to 7.4. The issue is till there. What should we done now?

Hi @ThinkGeneric,

Thanks for your reply. Kindly drop us an email at help@themepunch.support and we’ll check this out for you asap!

Thanks!

KC
ThemePunch