Oshine Core Plugin Error

wordpress

#1

I am getting this error and I don’t know how to resolve it. It occurs when I attempt to activate the Oshine Core plugin.

Parse error: syntax error, unexpected ‘[’ in /home/content/45/3196845/html/wp-content/plugins/oshine-core/inc/importer/init.php on line 128


#2

Fastest fix for that error is to upgrade your PHP version to at least 5.4.

Or you can contact the author for support here and they can advise: https://themeforest.net/item/oshine-creative-multipurpose-wordpress-theme/9545812/support

Edit – Other users have also posted this error in the item comments and the author said it requires PHP 5.4, so yes, definitely upgrade. Also, it’s worth noting that anything below PHP 5.6 can no longer be considered secure so I would recommend getting at least to 5.6. You can ask your web host for help with this. Cheers! :smiley:


#3

Unexcepted bracket means it could be the short syntax of an array I guess. Faced a similar problen recently in my CMS.

If you can’t upgrade your PHP version just replace all starting brackets causing this problem with array( and the closing bracket with ).

@allenherbert gave the correct and recommended answer to upgrade to PHP >5.4 because short syntax array’s have been implemented firstly since then.