No audio when rendering in MPEG2


#1

Hello,

I have a proyect/composition with an audio file, if I render the composition in AVI format (checking the audio output) it renders to .avi and when I play the video everything shows correctly, image and sound together, however, if I render it in MPEG2 it saves three different files; one .m2v, one .mpa and one .xmp. If I open the .m2v file the video plays but there is no sound on it, if I open the .mpa file the audio plays but with no image, so it’s like After Effects ends rendering the video in one file and the audio in another file.

Any ideas?

Thank you!


#2
mxfrodriguez said

Hello,

I have a proyect/composition with an audio file, if I render the composition in AVI format (checking the audio output) it renders to .avi and when I play the video everything shows correctly, image and sound together, however, if I render it in MPEG2 it saves three different files; one .m2v, one .mpa and one .xmp. If I open the .m2v file the video plays but there is no sound on it, if I open the .mpa file the audio plays but with no image, so it’s like After Effects ends rendering the video in one file and the audio in another file.

Any ideas?

Thank you!

My suggestion when you finish renders in After Effects than you convert the video using Adobe Media Encoder.


#3

Hi Yeremia,

Sorry I am very new to this, what you exactly mean with converting the video using Adobe Media Encoder? Could you please provide more details? I have two files, one .m2v only with the video and another file .mpa only with the audio. What should I do?

Thanks!


#4
mxfrodriguez said

Hi Yeremia,

Sorry I am very new to this, what you exactly mean with converting the video using Adobe Media Encoder? Could you please provide more details? I have two files, one .m2v only with the video and another file .mpa only with the audio. What should I do?

Thanks!

Just put your .avi files to Adobe Media Encoder and than you can converting to MP4. Or you render the project with Quick Time format don’t forget to checklist the audio when you renders. and than you convert the final renders using Adobe Media Encoder.


#5

I just don’t understand why After Effects has the option to render in MPEG2 in small size and great quality if it then splits the video and the audio. Why would anyone want that? I want to render video and sound together, that is why I put them together in the composition. :wink:

Anyways, I will try your advise with Adobe Media Encoder.

Thank you so much!!!


#6

MPEG-2 is used on DVD’s for example,where you need to have the video and audio separate so people can select different languages etc…i think.


#7

Dude, relax:) All is goooood :slight_smile:
What setting of MPEG-2 in AE are you choosing for output?
Clearly you are using a wrong one;))) What version of AE Are you using?

Generally, MPEG-2 files Elementary streams or Programs streams. In your case you have Elementary streams - this way you have 2 separate tracks at the end. Meanwhile if you select Program stream stream, you’ll end up with normal video+audio track. (Not all players playback MPEG-2 files with sound embedded, to check if all is good use VLC for that)

Hope that helps. If not - you can contact me and I’ll help you out like a lightning:))))


#8

Hello rendertom,
I am having the exact same problem. I am using CS5. When you say select Program stream stream, where is “program” is it in a dialog box or menu? Thanks!
p.s. I am really unfamiliar with the process so the more concise you can be, the better for me. I just need that format WITH audio included in the file.
Thanks…again

rendertom said

Dude, relax:) All is goooood :slight_smile:
What setting of MPEG-2 in AE are you choosing for output?
Clearly you are using a wrong one;))) What version of AE Are you using?

Generally, MPEG-2 files Elementary streams or Programs streams. In your case you have Elementary streams - this way you have 2 separate tracks at the end. Meanwhile if you select Program stream stream, you’ll end up with normal video+audio track. (Not all players playback MPEG-2 files with sound embedded, to check if all is good use VLC for that)

Hope that helps. If not - you can contact me and I’ll help you out like a lightning:))))


#9

Ok Guys I know the post is one month old but I would like to share the way to fix it, I had same problem for few hours but find the way to fix it,after adding to render queue choose MPEG2 format and check audio output then click format option, in new window click multiplexer and from drop down basic setting choose MPEG2, thats it.
BTW using AE CS6.