Minimum PHP version for Codecanyon project


#1

I have decided to go with Laravel right now but i have a confusion about minimum php version as Laravel 5.1 requires php 5.5.9.
What do you think about making this as a minimum requirement for the project?


#2

Should be fine as long as you clearly mention it in the item description. You could even go as far as recommending a few hosting providers who run that version


#3

Check statistics first http://w3techs.com/technologies/details/pl-php/5/all as you can see 5.5 is not widely adopted yet so this can narrow down your potential audience. I would go with Laravel 5.0 & php 5.4 and maybe upgrade later on.