"Media Pending" inside of Premiere has been disabled from VideoHive

Today I got a email my approved Premiere Pro has been disabled from VideoHive for a customer attention. They said :

A customer has brought to our attention that this item might contain missing or improperly linked media, which displays as “Media Pending” inside of Premiere.

Please investigate and correct any possible issues.

But in my computer its open it in premiere pro 2014 and 2018 and work properly without any issue. Also this item has 8 sales, and may be 1 customer facing this issue. This customer also sent a screenshot of this issue

So can anyone help me how to solve this problem in premiere pro. (this is 100% premiere pro project no need after effects installed.)
In this project I used 8 mov file with photo jpg codec.

Hi! :raised_hand: As you know Apple no longer supports «QuickTime PNG RGB+Alpha» format, so the last MacOS Catalonia dosn’t see the files in this format. All author must update their items changing all files format to «QuickTime Apple ProRes 4444 RGB+Alpha». But it’s about files with alpha channel.
I don’t know what about “photo jpg”. Maybe it also no longer supported. Probably the last client has Catalonia MacOS on his PC, and the first 7 didn’t update their Mac system or use Windows OS

1 Like

Does apple support “JPEG” image sequence ?

I don’t know. You can use «QuickTime Apple ProRes 4444» for sure

Mac OS Catalina still supports PhotoJPG codec. Even if it wouldn’t, Premiere brings his own decoder for Quicktime files. The restrictions romlam mentioned only apply to stock footage / motion graphics categories, although it is probably best practice to avoid Quicktime PNG in templates as well (should Adobe stop decoding those as well after Apple started with it).

So this is not a MacOS Catalina issue.
This sounds like a missing file error. You did include the .mov files in the zip of your template, I guess? So maybe the user either moved the project file to a different location or (most probably) he tried to open the project from within the zip file.

If you like to, you can send me the template and I will take a look at it.

I already sent you the template link through your profile page. Thanks Creattive

@chinmay3d We’ve been seeing this same issue with other projects as well, and it appears it might be a problem with the latest version(s) of Premiere Pro.

Please read this article, which might be of some help:


Well, I followed these tips to fix this issue. I also sent the file to Creattive for personally check on the issue. He said works without issues on his computer. I also checked 2 different computers in premiere pro cc 2014 and 2020 and works here without any problem. And I will upload it for review and I don’t know what happens next in mac because I don’t have mac.

Again Soft Reject Because it not working on mac :frowning:

I personally only work with Premiere Pro CC2019.1 and haven’t yet run into this issue, maybe you could try porting or recreating this project for this version? Perhaps then you won’t face this bug :worried:

Well I just replace all quicktime files to jpg sequence, now no quicktime file in my project. Anybody here who using Premiere pro in mac and Please can you please check this file in your MAC.

I dont have Mac. and because of Covid 19 my country is on lockdown so I am not able to go outside to check it in any Mac.

If anybody confirm then I will send file.

Hey @chinmay3d, just upload the file to the queue and let me know when it’s resubmitted. I’ll take a look as soon as I can.

Some links to other potential solutions that @MarkBrodhuber was able to dig up:

Thanks for fast reply. I just upload the file to the queue , Please check it.

@chinmay3d The issue is still occurring, but I need to perform some tests on my end based on the new information Mark found today. I should have an answer for you tomorrow. Thanks for your patience!

1 Like


I believe we may have found a solution – or at least a temporary workaround until Adobe releases a permanent fix. The issue appears to be hardware based, and following the steps in this article resolves the “media pending” issue.

We’ll approve your file for sale again, but should you encounter any customers asking about this, please refer them to this forum thread, or the Adobe link above.



Hi, many of my clients are having problems like this with Premier Pro 2020.
I led them here and to the common connections of the solution.
Has a definitive solution been found?

Hey @radrets, the solution in this article worked for me. I’m on a Mac, using the latest version of Premiere, so I haven’t been able to test whether or not this solution also works for anyone who might be experiencing it on a Windows PC.

As for a definitive solution, we likely won’t have one until Adobe provides an update for Premiere. I’m not sure if that would even be part of the next release or not.

1 Like