Logic Pro X / Kontakt Issues


#1

I’m getting a lot of errors lately saying the audio engine couldn’t process the info fast enough. This causes playback or recording to stop abruptly. I don’t remember this happening much in the past. I use Kontakt as multi-timbral and I’m now working on a piece that has only 5-6 tracks and it’s already bogging down!

Gear

iMac 3.3Ghz i7 QuadCore w/ 32gb RAM
Kontakt 5.5.1
A simple M-Audio 88es controller

I keep wondering if this is an issue of enabling/disabling the multi core support in the host or perhaps in Kontakt. They both have the setting. I’ve gone back and forth but it doesn’t seem to change.

Any suggestions as to how I should setup to optimize performance? Thanks for any help.


#2

Nah, I’ve noticed on my Macbook Logic tends to have an insane amount of threads open - like 20+ - so Logic relies heavily on multi-threading BUT It will open a crazy amount of threads regardless of what you have your “processing threads/cores” set to in Logic, and it’s running fine on my old Macbook from 2008 with 2 measly cores and a measly 2.4 GHz core 2 duo. Kontakt on the other hand…who knows. IMO, sometimes they screw their stuff up when they release newer versions, and I’ve had some weird experiences with Kontakt. After awhile, having made no changes to the Kontakt settings whatsoever, Kontakt just started loading samples extremely slowly for me (and we are talking on my PC with SSD.) The issue has since resolved itself somehow, but pretty weird stuff. I would highly suspect the issue lies somewhere in Kontakt over Logic…


#3

You Kontakt on each track? or only the first, but on other tracks are already multi-channel MIDI?


#4

I open just one instance of Kontakt with 10 channels in multi-timbral


#5

I’ve enabled the Kontakt Memory Server to see if that will help.


#6

Have you clicked on the button “Purge” in Kontakt? What would not loaded memory?


#7

I have a similar situation.
There were noticeable clicks and pops even if a small instrument loaded (H/W buffer size = 128 samples). Kontakt Memory Server didn’t helps me. I set Kontakt’s multiprocessor support to “off”, much better, but I’m still in testing.

mac i7 Quad Core 2.6 Ghz, 16 RAM OSX 10.10.5
Apollo Twin
Pro Tools 12.1.0
Kontakt 5.5.1 w/ SSD 512

What is the size of the buffer in your host?

UPD: everything is perfect now


#8

It’s a Kontakt tweaking issue, I beleive.
I found a good article:


#9

That I suspect is your issue, Logic does not handle multi output VI multithreaded, Apple actually recommend not working like this but to use individual instances.