Link Expired?

Hello all.

I just bought Royal Audio and downloaded it, and when I go to upload it into my WP site, at the end of the upload, it refreshes the page and displays “Link Expired”.

Can somebody help me with this issue?


Hi, I am also having the same problem! feeling somehow cheated :frowning:

Hi @YBSMike and @claudia_marques!

This error typically occurs when the file you’re uploading to WordPress is larger than the maximum file size allowed by your web server. You have three options - click the links for more details:

Hope this helps! :slight_smile:

Renea smussen,

I am working on the three options they provided to be able to get that Plugin into the website.

I have changed the settings to allow for the larger file, no luck.
I even uploaded the whole plugin into the plugin directory through FTP, but it won’t show up in the WP plugins when I check to find it.

I get the same error even after I added a USER.ini file (new install) onto the root (html) with these settings in it:

upload_max_filesize = 160M
post_max_size = 160M
max_execution_time = 300
memory_limit = 256M

the exact error says: The link you followed has expired Please try again.

If I manually upload the plugin, do I just unzip it and upload all the folders into the plugin folder or, is there a specific folder set that I need to upload from within the zip?

I’m starting to think that the author set a time limit on the zip file, and it’s now expired.

I have spent about 6 hours on this so far. I appreciate any help!

Download the “installable WordPress file only” from your downloads page. Inside this archive should be a single directory with everything inside it. Upload that entire directory into /wp-content/plugins/, and it should appear.

Ok, the main folder once unzipped is: codecanyon-6444965-royal-audio-player

Inside of that are 4 folders:

  1. Documentation
  2. js
  3. Psd
  4. start

I just can’t see leaving any of them out but maybe Documentation…

js = java
Psd = photoshop
start has sub dirs: content and js and more, so it’s def part of the plugin. I did write to the author, and am awaiting for his response.

I appreciate the input, but I can’t see anything that I could leave out. I even re-zipped the file just to try it and same error.

You downloaded the wrong file, that is “all files & documentation”. When you click the Download button, choose the installable WordPress file only.

Actually, upon looking at the item from the file name you provided, that’s not a WordPress plugin. It’s a JavaScript item by @FWDesign for developers and designers to use on their websites.

Here’s the WordPress version:

Are you kidding me? :slight_smile:

When I look at that link, I see the exact same thing in the picture as when I did when I bought what I thought was the audio plugin! I did wonder why it was only $19 though. I have to also assume that Renea smussen did the same thing. I’m actually glad to hear it! Thank you for taking the time to look into this for me, I greatly appreciate it! Are you with the website or the author?

Wait a minute, It does not look like I got the wrong file.

I’m starting to think that maybe they put the wrong file in the link or in the zip.

Edited to change picture to show download options…It ISthe wrong file as you said.

You did purchase the wrong one. Many authors will provide different versions of their items for different platforms, and you’ll need to grab the WordPress version to use it for a WordPress website. If you click on the name of the item from your downloads, and check the category (directly above the title), it will say JavaScript. The WP version also has WordPress in the title, and “WordPress” at the top of the thumbnail and banner. Look closely:


Hmm, what do you mean? I’m a fellow customer and also an author; I’m not affiliated with @FWDesign or the item you purchased.

Yes, I did see that when looking further! I edited the text to agree with you once I looked deeper. Sorry about that!

I asked if you were with @FWDesign because I wanted to know how to go about swapping what I bought out with the proper version, but I have since wriote to the author!

Thanks much for your help!!