Javascript on Xampp


#1

Hi everyone,

I’m trying to put a JavaScript slider on my home page in my Wordpress theme for ThemeForest. I’ve done everything the help file has said I need to do but it doesn’t seem to be working.

I’ve linked to the exact location of where the JavaScript files are but it just doesn’t seem to work. I’m so confused. I think it might be something to do with my local server…

Any help would be awesome!


#2

Xampp shouldn’t have anything to do with JS not working.

Just make sure the JS file links are correct. One short way is open the page in firefox. Right click and view the source. In the source, click the link of where the JS is located (the src in the script tag) and if it leads, its fine. If it doesn’t find it, its probably a wrong location.


#3
Xampp shouldn't have anything to do with JS not working.

Just make sure the JS file links are correct. One short way is open the page in firefox. Right click and view the source. In the source, click the link of where the JS is located (the src in the script tag) and if it leads, its fine. If it doesn’t find it, its probably a wrong location.

The link is fine though. I used firebug in FireFox to check the links in the header and they linked to the JS file. I’ll double check it again.


#4

Which Slider are you using?


#5

Do you use FF plugin like WebDev tools or turn on FireBug console? It could help a little if anything seems goes wrong in the script that make it did not working.


#6

I’m using this slider: LINK

I have FireBug installed on FireFox.


#7

Try to get it work on a single page… and then include it into your WordPress.


#8

it’s most likely your path to your javascript files is wrong, other then that if you include the JS through Wordpress, you need to use the jQuery(’…’) tag instead of the $(’…’)-tag


#9

OK I’ll check it over again. I’ve been working on this theme for over a month now and have decided to get everything working this week so I can start on the documentation this weekend.