Installing themeforest on Joomla 3.x


#1

I have been unsuccessful in installing themeforest with Joomla 3.x. I used a file upload to put the quickstart.zip into the root of my site then extracted it. The template does not show as an option under Joomla. That is all the instructions said to do.

Any ideas?


#2

Hi @ifoto_boise,

Welcome to the forums! What is the name of the theme you have purchased on ThemeForest?

Thanks,
Luca


#3

@ifoto_boise Normally with Joomla, you can’t install the quickstart in the Extensions > Install. You’ll have to run the quickstart like a Joomla installation. Extract it in your public_html then go to the URL to install it. I hope that helps.


#4

The theme is nicanian_ii


#5

I did as you suggested from the start. The problem is when I go to access my site I get an SQL error:

404 Error
Table ‘ifo1813503101897.jos_contentitem_tag_map’ doesn’t exist SQL=SELECT m.tag_id,t.* FROM jos_contentitem_tag_map AS m INNER JOIN jos_tags AS t ON m.tag_id = t.id WHERE m.type_alias = ‘com_content.article’ AND m.content_item_id = 24 AND t.published = 1 AND t.access IN (1,1)

I started with a fresh Joomla 2.5x install then upgraded that to 3.3. At that point the site worked but with their sample content. Once I unzip the quick install then the site is broken. I tried it with Joomla 2.5X and various other version but with the same results.

Also just unzipping the quick install does not seem to add the template. I had to additionally unzip package_template.zip. I tried uninstalling Joomla and deleting the database and starting over but same issue. Not sure where to go from here.

Thanks


#6

Are there any version of Joomla, beyond 2.5, that this doesn’t work with?

Is it necessary to unzip package_template.zip in order to add the template?

I keep getting errors like this one:

Fatal error: Class ‘JLayoutHelper’ not found in /home/content/94/9651794/html/plugins/system/t3/base/html/com_content/featured/default_item.php on line 33

I should add that when I go to look at the template details it tells me I have to first install the T3 framework plugin. There is nothing about this in your directions. I installed the plugin but get the error above.


#7

Also, the directions say I need to install the T3 framework plugin. The T3 downloads page says the version works with Joomla 3.8. So I updated Joomla to 3.8 but now loading the site says it can’t find the Beez template.

Any help???


#8

Hi @ifoto_boise,

I think you should contact @templaza, the author of Nicanian II theme for support:

Thanks,
Luca