How to get rid of product variations on Woocommerce Cart?

Hi, everyone. I am using Mango theme and Woocommerce.

On Cart, product variation (Not attribute) is displayed under the product name.
If it is displayed with its attribute name, it is OK but attribute name is not displayed with it.
So, I’d like to display attribute with variation, or remove variations on Cart.

http://www.dressance.com/cart/ On here, 21, 31 under the product name are variations.

I tried http://stackoverflow.com/questions/38681192/remove-variations-from-cart-page/39217581#39217581 and adding ".woocommerce-cart .variation {display | none ;} to Custom CSS.

Both did not work.

Anyone can help me. I spent three days to resolve this problem.

Hello there,

What you’re asking is considered as theme customization and you should hire someone for it. If you’re OK with it, I could help you on this. Just send me an email to gmail(at)moskvayigit.com or purchase bug/fix service from the link below:

Best,

Yigit

Dont you want people to know what size they are buying?

Anyways you can use:

li.cart_item .product-desc-list {
display: none;
}

Hello

Removing the variation is very easy.

Step 1. Login to wordpress
Step 2. Go to Products and search for your product
Step 3. Product Data - select Simple Product
Step 4. Save

Thank you for your comment.

However, this is not the solution, because I need the variation to process the product.

If I make it Simple Product, I can’t build the variation.

I just do not want it is displayed on Cart without its attribute name.

Thanks though.

ok, then simply copy/paste the css code that you have in the child theme style.css at the end.

Can you tell me more exactly?

What CSS code?

I tried to insert “.woocommerce .variation {display: none;}” into Custom(Quick) CSS but did not work.

Thanks.

insert without quotes, if is not working try this

.woocommerce .variation {display: none !Important;}

If is not working, let me know and I will take a look tomorrow for you

It does not work.

And I need to use .woocommerce-cart instead of .woocommerce, If not variation will not display all woocommerce page even if it works.

I just do not want to be displayed on Cart and Checkout, or displayed with attributes.

The reason is that we do not understand what variation (because it is number) stands for by itself.

Thanks.

Jay

I looked at the html structure and this is what you need to add

.woocommerce .product .product-meta .product-desc-list { display: none; }

HI,

I inserted it into the Custom CSS of theme options.
But it is same. Nothing changed.

When I switched to twenty sixteen theme, no variation is displayed.

Thanks.

Jay

then go to your child theme and put the css there. I added the code from firebug and it worked

1 Like