How to Change Credit Card Icons in Footer in Flatsome?

Hi - I recently purchased the Flatsome theme and I am in the process of setting it up for my business. I have a question regarding how to modify to credit card icons at the very bottom of the footer. I cannot find the place in the editor to do this. Can you share with me where I will be able to add/modify/delete these approved payments?

check it in this file “footer.php”

Actually it was a bit more complicated than that and I found out how to do it. It’s not straightforward, and it’s a shame there doesn’t seem to be something built into the theme/UX that allows an end-user to easily swap out their preferred credit cards.


That file contains the icons that are currently being displayed at the bottom. As a test i removed one of them (cash on delivery) and it worked. Now i just need to figure out how to add in new ones.

Hello @MondoMelon,

Usually, the social or credit card icons from a theme footer can be added/removed/changed from theme settings admin panel.

It’s not recommended to make code changes directly in theme files, because with the future theme updates, you will loose those code changes (unless you set up a separate child theme).

Anyway, for further specific assistance, you can contact the theme author here:

All the best!


You can change the payment icons via the Theme Options → Shop → Payment Icons page.
It shows a list of payment options and you click the eye icon to show or hid it.

It’s explained in the documentation here:



I’ve replaced the standard icons by a .PNG file but it doesn’t follow the .PNG original size, what do I have to change? The uploaded .PNG file is like 100x50 but on screen it shows a much bigger image. Not sure how to fix this.

I selected “Absolute Footer” on Placement and it’s all fine, img on right size. thanks anyway!

Excelente, me ayudó muchisimo. Gracias!!

Where dose the url link data for the payment icons come from? It needs to change the protocoll to HTTPS !!!

I cant find the code that generates the url! Argg… it makes the browser show the site as “unsecure” !!!