Houzez Maps "for development purposes only" since Google changes

My API key is entered into the Houzez theme options, but maps are not working.

https://www.actionrealtyar.com/property/self-sustaining-farm/#prettyPhoto

Google Maps is no longer free, and they moved it to the Google Cloud Platform. You now need to have a Google Cloud account with a credit card or bank account attached, so they can charge you if you exceed their free tiers.

You can learn more and grab a proper API key here: https://cloud.google.com/maps-platform/

1 Like

Yes, I should have mentioned more details.

I am aware that Google Maps are no longer free and have a billing account already in place. I have followed the documentation instructions exactly. Billing and Quotas are generously set.

Clean install of WordPress, latest stable version 4.9.8
Clean install of Houzez template.
API entered into Theme Options

Specifically:
APIs Enabled in Google Cloud Platform Console for this project as per Houzez Documentation
Geocoding API
Geolocation API
Maps JavaScript API
Places API for Web

Maps JavaScript API entered into Theme Options as per Houzez Documentation

I have had this happen on another premium template from a different company. They updated the Theme and everything works on that one now, but I cannot get the Houzez maps to work on this theme. What am I doing wrong? Should there be a Houzez theme update to correct this or is it on my end?

Please do double check that you entered the correct API key then, as this message is only caused by an invalid Google Maps API key.

If it persists then it could be a theme issue. You can try contacting the author for support with it - here is their support information:

1 Like

Thank you. I followed every step for a third time around, even created a new Google account and billing account. Same issue, I’ll contact author support. Thanks again.

1 Like