Help: My Uploading of Stock Footage seems stuck.


#1

Thanks in advance for your help. I’ve been like one month without being able to simply upload any of my stock footage for Review. After finishing the uploading process, there’s no “next page”, where we fill in the data. I’ve tried three different navigators with no success. The format of the video is correct as the previous accepted ones. I still enter today to the uploading Stock Footage page, and it shows an old " Your videos are processing" message. Something seems like stuck. I appreciate the help, to see whats happening. I tried to write through the Help Center, and curiously, after filling the request, it sends me back to the general " ask a question" page to throw you back to some articles. If that’s not the correct way to write a request, please let me know the correct link. Many thanks, Dan.


#2

Hello. I had the same problem. Try to upload your video via ftp. I used the free FileZilla program and it helped, uploading works! Try it, here you can download the program for free: https://filezilla-project.org/
Best Regards
Achna


#3

Thank you for your feedback @Achna I will try it today!


#4

Hello again @Achna, I think for this you need also a domain to upload your material, before working with Filezilla? Sorry for my ignorance on this. I don’t know if there exist a free site to upload media material. 100 thanks! :grinning: