Google shows "Startup Demo - WordPress Landing Page Theme - Landkit" as my page title

When I type my website’s name in google search, it shows the title as “Startup Demo - WordPress Landing Page Theme - Landkit” although I have already customized the title field. How do I fix it???

Hi

Have you changed the title in wp-admin Settings => General Settings!

Thanks

Yes, I did it.

Is there any other possibility for this error?

not only google actually your site title has assigned the title you can see in google search. Are you using any seo plugin?

Your meta title and data is wrong - there’s no way you can have Yoast setup properly?

Ok, I am using Yoast plugin. I changed the Yoast SEO details.
Do you know how long Google takes to reindex the page with the correct title?

go to your Yoast plugin settings and set all meta data correctly and all will be fine. currently that
title is coming from Yoast meta settings. as I said not only google if you check view source of your page you will see that title exist in your page. so, you have to fix it through Yoast meta settings. Thanks

1 Like

It’s an ambiguous length of time. There are lots of reports that say between 4 days to several weeks but it’s hard to know for sure and you cant force it.

Why are you redirecting traffic? i.e. https://weage.com.br takes users to https://weage.com.br/site/

Another thing your blog page title is working fine. So, the problem is your front page. If your Yoast plugin meta settings are correct then please go to Pages and edit frontpage/homepage and see may be there you have set that title in Yoast meta data settings.

1 Like

Ok, I got it. Thank you very much for your kindful help.
:smile:

1 Like