Google Map Issue!!

Hello,

I am using Ironfit Crossfit theme. On home page there is google map but it is not visible . there is an error comming: js?key=AIzaSyAqxqCh3FML2As236p-hn9Qq3J6dBiCgr8:39 Google Maps API error: RefererNotAllowedMapError https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error

Your site URL to be authorized: http://localhost/Evolve1/?customize_changeset_uuid=f2cf004b-00e3-494a-a042-9563fad4217c&customize_theme=ironfit-child&customize_messenger_channel=preview-0

I am also trying to put different API key which is gererate automatically when click on first link but it stilll not working properly.

So, can you please give me solution?

  1. Maybe if your projects is on localhost you are getting this error.

  2. Also there are some changes in google maps api/integration (start today) - they are now start with plans and official there is no more “free maps integrations” but they will give you 200$ per month bonus for using maps (or something like that)

More you will find on google:

Or maybe is something else ::slight_smile:

*Link updated

1 Like

You should contact the author but you will need to log in using the account which purchased the item (no buyer badge on this account) to be able to access support

1 Like

I import local website on live.
But still getting same error.

Hello there,

If you are still struggling with RefererNotAllowedMapError, then I can recommend you 2 solutions. The first one - you have to add and enable Google Maps API project on your Google platform. The second one solution is about the list of referrers for your project - if you have set it up and you didn’t insert your domain name on it, then you have to do it. Otherwise, if it still doesn’t work, it may be caused by domain name which you have inserted before. More about it, you can find here.

1 Like