Global Illu Settings for Animation?


#1

Hey Guys,
I need your help, I have some probelms witz my animation currently. My animation flickers and I want to reduce that. How can I do that?
Or what GI render settings do you use for C4D?

Regards,
Anil :slight_smile:


#2

What version of C4D do you use?
Any ways, try to avoid using GI when animating, cause it will cost you pain + render times.
However, if you MUST use GI, and you are on R13 or above - use Physical render. That’s almost bullet proof solution for flicker free GI animation.


#3

Hi,
make sure you have changed the GI-mode to IC camera animation or to IC+ QMC camera animation.

Best regards and good luck! :slight_smile:


#4

Thanks guys, I will try both :slight_smile:


#5

As Leupsi said you need to set GI Mode to IR(+QMC) Camera Animation, but it will work if only the camera animated in your scene. If you have other objects animated, lights, etc. then you still will have flickering, in this case you need to set it to IR+QMC Full Animation


#6
murkin said

in this case you need to set it to IR+QMC Full Animation

and then you get a two weeks vacation while you wait for the animation to render :smiley:


#7

Also make sure the AA settings are high enough. Often very thin lines tend to produce flickering effect as well, no matter if GI was used or not…


#8

Check out Nick Campbell’s blog:

  • http://greyscalegorilla.com/blog/2011/03/how-to-optimize-your-scene-to-render-faster-in-cinema-4d/
  • http://greyscalegorilla.com/blog/2009/10/the-science-of-global-illumination-in-cinema-4d/
doru said
murkin said

in this case you need to set it to IR+QMC Full Animation

and then you get a two weeks vacation while you wait for the animation to render :smiley:

+1. But this is not too much :wink:


#9

Yep, and after 2 week you still get ugly result, that you won’t use, as it’s still flickering:)
By the way, also make sure your shadow quality settings are balanced and don’t introduce shadow flickering.

Make sure you are rendering you resolution you need and not higher.

Check your AA settings.

Include channels in Multi-Pass render.

Make sure you render to TIFFs instead of MOV or AVI file.

Check your alpha channel if you need one.

Disable AO for this render and do AO render AFTER your initial rendering is done.

Check your blurry reflections - do they really need to have that high settings?

Check your GI settings - how many bounces do you have ON?

Maybe switch to render without GI.

doru said
murkin said

in this case you need to set it to IR+QMC Full Animation

and then you get a two weeks vacation while you wait for the animation to render :smiley:


#10

In Cinema 4D 16, Global Illumination for animation works for me with these settings:

  1. Global Illumination > General > Exterior - HDR Image
  2. Save > TIFF or PSD format (with alpha channel you need for compositing)

This is the best compromise when turning off Global Illumination doesn’t give you the light quality you need.