Get Started With Angular 2 zone.js install error

Hello, and my apologies if I’m not in the right place to post this question:

I’m running the Get Started With Angular 2 course and:

question 1: I don’t see any links to download any of the script files used in the lessons so I’m typing by hand (ugh), are none available? Required upgrade to my account?

question 2: In my package.json file one of the dependencies is “zone.js”: “0.5.11” .
In movie 2.2 Setup the Angular 2 project I ran the “npm install” from within my project folder at the command line. I received the following error:

npm ERR! Failed at the zone.js@0.5.11 postinstall script ‘tsd install’.
npm ERR! This is most likely a problem with the zone.js package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! tsd install
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs zone.js
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR!
npm ERR! npm owner ls zone.js
npm ERR! There is likely additional logging output above.

There is a generated log file (it’s huge) and I did a find for “tsd install” and it basically repeated the exact error I posted above, then referenced how it gently removed it because of the error.

Anyone know what this problem is? Is the version of zone.js now out of date?

Any help is appreciated!


Hi Rich,

There should be a View on GitHub button on the right hand side of the screen. It links to the source repository for this course. If you go there, you can clone the repo to your local machine using git or you can just download the source as a zip file (click the green Clone or Download button in the upper right corner).

(If you want to debug your code, you could start by comparing what you have to the source code in the repository.)

Thanks Adam

I was able to sort it out and actually go to run the project but I’m getting a 404 error because the file /app/app.js can’t be found. I searched my entire machine and can not find a file called “app.js”, however there’s a reference to it in my index.html file that Reggie had us input during movie 2.2 (Setup). Can I generate this file myself and/or redirect the paths myself? It all seems like it’s generated code so I’m afraid my changes will just get overwritten.

Specifically Reggie’s code has us defining /app/app.js, however even though the folder is exists the app.js file does not. Was it supposed to get generated?

Thanks again for your help, very grateful.


Hi Rich,

Since this project is written in TypeScript (.ts files), a transplilation step is required to produce the JavaScript (.js files). In this project, you should be able to run npm start to start the transpiler and server, or just tsc to do the transpilation step.

Take a look at lesson 2.2 for more detail about installing Node and setting up the project.

Hi Adam

I did as you suggested and ran npm start to run the transpiler in my shell window and it returned with an error:

Tell the author that this fails on your system:
23 error tsc -w

So I found that line in my package.json file under scripts where it says "“tsc:w”: “tsc -w”,

A google search came back with that’s the typing service, and when I tried to run “tsc” or “tsc -w” from the command line I got a “command not found” error…

FWIW I’m running Node v 4.5.0 and NPM v 3.10.8 on Mac OSX 10.11.6.

Any ideas?

Thanks again,