Facing Error in Theme Setup on Local Server

Hello,

I have purchase theme, https://themeforest.net/item/vitrine-woocommerce-wordpress-theme/19951364,

But after downloading while setting up theme on local server i am getting error like,
Parse error: syntax error, unexpected ‘[’ in C:\xampp\htdocs\Hiralal\Hiralal_Jewelry\wp-content\themes\vitrine\vitrine\lib\shortcodes\shortcodes.php on line 4464

and while i try to upload theme in wordpress manually, i am getting this error.

"and the error that says:“The link you followed is expried”

So, help me to get out of this error. Provide me solution.

Thanks,
Nirav

1 Like

Hi,

I had a couple of times this error on my items (core plugin for themes):

Parse error: syntax error, unexpected ‘[’

And in my case is always because of PHP varsion - if the PHP version is lower then 5.4 I am getting that error. So, maybe you can start from there - to update your PHP version if is old one (maybe this is not in your case, just saying).

Best

2 Likes