Enfold 5.0 not compatible with Wordpress 6.5.2

I am attempting to install Enfold 5.0 at Godaddy… they are running Wordpress 6.5.2 Is it true that Enfold will not work on this version of Wordpress?

Hi,

You can ask your query directly to the Item author by posting comments going through the Item Comments page.

Or send them a direct email going through the author profile page in Envato market, there you will find a contact form.

Thanks

It will probably work, you can just try to install if you have already purchased the theme