Compatibility of After Effects Templates

I am still using the Adobe CS5 versions of AE and Premiere. Will the templates available in subscription downloads be backwards compatible with those versions?

Thanks!

It depends on how the items are made. For example, if they use features available only in CC, then you will have issues using it in CS5. It’s sort of up to the author if they want to make their items compatible with legacy versions.

I’m surprised that Elements doesn’t show compatible versions in the item info since it does on the Marketplaces, so unfortunately it doesn’t look like there’s any guarantee that an item you download from Elements will be compatible until you try it.

1 Like

Thanks for the info. I will probably purchases a subscription for the improved workflow eventually - after trying a few in CS5.