Cinema 4D Chunky Reflections


#1

Hey all!

I’m totally stumped and thought maybe someone here could help. I bought some phone models from 3d02 for Cinema 4D and I’m having a lot of issues with the reflective materials, they are rendering super chunky. I tried everything I could find, increased the anti aliasing to 16x16, phong tag and nothing seems to effect it. Am I perhaps missing something?

Thanks!
Louis


#2

a screenshot will help to identify the problem


#3

Oh, good idea! I posted the image below.

The below render is 16x16 anti aliasing. I have this issue with all of the phone models I purchased.


#4

Check if the material you’re using isn’t “sketch and toon”. Second thought: maybe light is too strong so reflection is overbright.


#5

Are you using Greyscale Gorrila Lightkit pro? if so, it might be the linear workspace that’s causing the lights to blow out.


#6

Thanks for the suggestions!

I checked and the material isn’t sketch and toon. I am just using 3 planes above the phone with luminance for lights. I tried to lower the intensity and still no luck. I still get these weird angular/chunky reflections.

Officially stumped!


#7

Maybe smth wrong with material reflection parameters. What settings you use ?
Can you show them ?


#8

Another option would be
replace the phone with a sphere instead, apply the same materials to the sphere and render to see if its a model issue or material issue - very likely to be a material issue or setup in your lights
If you can save the project and put it on somewhere (with the sphere REPLACING the phone model obviously)
It would be easier to help you out.


#9

You guys are awesome, thank you so much for trying to help me out!

I attached 3 new photos. First is a sphere I put in the same place with the same material, it renders beautifully! lol. Second is material settings and a third is a close up of the problem on the phone. It’s so odd - this is happening with all 4 phones I purchased and I’m starting to really fall behind schedule and getting in trouble with this lol.




#10

Is it a Phong Tag problem?

Select the object and click the Phong Tag (two little orange circles icon next to the material), try making the Phong Angle higher.

EDIT Ah, you already checked the Phong Tag, sorry!


#11

Thanks for the suggestion! I gave it a try, cranked it all the way up and it didn’t seem to change it.


#12

The only way I can replicate the problem from your screen shot is messing with the Phong Tag. If you create a torus object and in its Phong Tag set – Angle Limit Checked, Phong Angle 0 degrees and Use Edge Breaks unchecked – does it create the same issue?


#13

No, that’s the odd part, this issue is only coming up on the models that I purchased. If I use a torus or sphere it looks smooth and beautiful.


#14

I noticed that all the elements for the phone are under a null object, which has its own Phong Tag. Maybe try taking the phone elements out of the null?

Otherwise it seems like an inherent issue with the geometry, like the Phong Tag isn’t working because the polygons are disconnected or something (I’m no C4D expert!).


#15

I think you figured it out! I think it’s a geometry issue. I ran “optimize” on the mesh and it made the reflection start to look normal but it’s still all jaggity.

I’m thinking now the issue is with the model I purchased. I think it wasn’t made in Cinema, it was just converted to .c4d somehow and that must have messed it up? Ugh, bummer lol.


#16

Got it! After playing with the optimize numbers I got it looking like a normal reflection! Couldn’t be happier, you are a genius, thank you so much and thank all ya’ll that took a look for me!

So anyone who comes across this with the same problem if you bought some boot leg model like I did make sure to optimize haha.

=D