Cant upload recently purchased plugin

Getting this message whne I upload my purchased plugin.

The package could not be installed. No valid plugins were found.

Help!

Hi

You have to install the plugin zip not the full download (All files & documentation) zip. Please unzip the main full download (All files & documentation) and then locate the installable plugin zip file within it. Luckily most developers clearly label their files, so it should be pretty easy to find. you have to install that plugin zip.

Thanks

BINGO! Many Thanks!!