Can't get "Getting Started with Laravel 5" app to serve in macOS

I’m working my way through the “Getting Started with Laravel 5” course on Tuts+, and Homestead and the rest installed fine, my command-line output matched the instructor’s, etc., I go to load into my Chromium-based browser…and I get an ICANN error.

A bit of googling later, I figure .app becoming a registered TLD actually makes some sense, so I tried changing it to .test or .anythingElse and, even after reprovisioning the VM, browser says it can’t resolve the DNS. Am I doing something wrong? (Safari is actually worse; it tries to search for the URL I wish to call.)

I’ve used vagrant boxes at previous jobs before, but getting them up and running was always Someone Else’s Job. To say google hasn’t helped would be putting it mildly, so…anyone else tried to work through this course and had the same problem? Yeah, I could just watch the course without following along, but I’d rather not.

It sounds like you’re on the right track switching the .app domain for .test. What error do you get on the .test domain? Is it the same ICANN error?

Just your general, “I have no hecking idea what you were trying to do,” error.

I’m not super-fluent in *nix-based systems, so I may be overlooking something painfully obvious… I did try editing my host file to point laravel.test (and bookmanager.test from the Lumen course,) to the Vagrant box, but now both Chrome and Safari are actually searching for laravel.test and bookmanager.test instead.