Can't download anything or submit help request - Google API issue

I can’t download items off of Envato Elements anymore due to a Google API Recaptcha issue. I’ve tried multiple browsers, cleared my cache and made sure that my internet is properly working. I found 0 issues on my end. I messaged you guys on Twitter and Facebook because I can’t even submit a ticket using your help service as I get the same issue there.

This is extremely urgent as I have client projects that I need to finish up (I’m sure that’s the case for everyone here, however it’s still worth mentioning).

2020-04-25 11_18_50-Musik - WordPress Admin Theme by Flatfull on Envato Elements - Personal - Micros

Hi

Please contact Elements Support. Elements Support Team will be happy to help.

Thanks!

Hi mgscoder, I’ve tried doing that but I can’t submit a ticket. I get the exact same issue as described above.

Clicking the button does nothing.

it should to work. please can you check with different pc.

I’ve tried multiple browsers and multiple computers and I always get the same issue. I know it should work but it doesn’t. It started happening as of yesterday.

you can check back tomorrow in the mean time you may get reply on social media.

Hello @Aletarius

Until then:
I’ve seen this error before on another website, I was able to fix it by completly refresing my internet connection (most probably the Google servers store some wrong URLs coming from your internet connection)

These are the steps to completely refresh your internet connection (the bookmarks, the system or custom work will not be affected):

  1. Open the command prompt as administrator ( here is how: https://www.howtogeek.com/194041/how-to-open-the-command-prompt-as-administrator-in-windows-8.1/ )

  2. type this command in the command window then hit Enter (this command will clear all IP entries cached on your computer):

ipconfig /flushdns

  1. type this command in the command window then hit Enter (this command recovers the computer from any socket error after some file downloads, old URLs, bad scripts, etc.):

netsh winsock reset

  1. type this command in the command window then hit Enter (this command practically refreshes the TCP/IP protocol):

netsh int ip reset

  1. restart the computer.

Thanks for providing this information but unfortunately it did not solve the issue for me.