Can I use any theme with my Wordpress 8.0.1

#1

I will buy my first template but I not sure if all templates works with my Wordpress 8.0.1

#2

All themes on themeforest must work with WP 4.8

#3

All NEW themes have to work with 4.8

As long as older ones worked with the latest version of WP when they were released then some of the older themes may not have been updated to 4.8 compatibility