Avada theme: Blog meta date not responding to changes

The blog post meta date is in a form that is grammatically wrong in my language. I’ve made sure that it’s in the correct form in the Settings and the selection is empty on the Avada Global Options - Blog Meta - Date form. How can I change it to the form I want, or have the changes I’ve made visible?
I would like to use the existing Global options by Avada for the blog to keep it simple, and just create it without grammatical errors on the meta date.
#themefusion #avada

You can get some support from the author: