Ask about W3C, html and some WP Plugins

Do you pay much attention to this standard? I checked html-view some plugins(with wordpress.org) on W3C-validator and it have Errors. Can I use them in my theme?

Depends what the issue is and as with any plugin you would need the correct
License and/or permission to use it regardless of W3C

For example, Smart Slider 3, it give next error: