After Featured Image Deleted It Still Reappears


#1

Hello guys. I am using REhub theme for my site (lastdaydeal.com). And, In the last two days i’ve noticed something strange which have never experienced before working with other themes. Every time i delete the Featured Image from the post and delete from the Media Library, the same image appears again on the post and in the Media Library. How can this happen?

I was thinking maybe the cache (W3) was doing the trick but then checked that also and i didn’t notice anything unusual. Basically i have kept doing this (Remove Featured Image from the post -> Delete the same image Permanently from Media Library -> Save the changes -> View the post/refresh post and that same image appear again on the post and Media Library) for the last two days

Does anyone has any thought, idea where, how to fix this?

Many thanks in advance,
Eddie


#2

Have you cleared your browser history? Tried it in another browser?


#3

Hi Charlie

I use private browser. But again i don’t have same experience while simultaneously work with another theme on the same browser. This happens only on this particular theme


#4

I am worried if the theme has any (trap code installed) making this unusual effect?


#5

It’s very unlikely - that sounds like a cache issues esp if you are even deleting it from the media library. Is your WP version and the theme up to date?


#6

Yes it is


#7

Strange!!! I just deactivated the (W3) and the issue is not happening…I don’t get it…


#8

It has to be cache related - maybe a conflict with the theme and plugin

Try tirining plugin back on and see if it comes back


#9

I am testing the Page Cache Option between Basic and Enhanced Option. Looks like the enhanced option is doing this. I will keep testing it for few more times to make sure it’s the one doing the effects


#10

Returned it back the Enhanced Mode and it didn’t bring back the same image. Tested it in both modes - Basic and Enhanced back and forth few times and looks like the issue disappeared.

Looks like that switch back and forth between those two modes fixed the issue.

I will keep monitoring the changes.

BTW, I Thanks you very much Charlie for your help